Музыкальный альбом

Описание программы

Вы хотите сделать коллекцию мр3-музыки на компакт-диске с автозапуском? С красивым интерфейсом профессионального качества? Тогда эта программа - для вас. Она представляет собой готовое автоплей-меню, которое нужно лишь немного настроить, загрузив туда музыкальные файлы, картинки и комментарии. Коллекцию можно использовать и на компьютере, так как в программу входит полноценный мр3-плеер. Множество сменных интерфейсов позволят вам создавать музыкальные коллекции на любой вкус!

Программа позволяет создать меню с несколькими сборниками музыки, число которых может быть до 12. К каждому сборнику вы можете загрузить картинку и добавить текстовый комментарий, которые будут отображаться в интерфейсе программы во время ее работы.

Во время работы Мастера настройки вы сможете выбрать один из готовых красивых видов дизайнов интерфейса, которые выполнены в стиле известных программ. В комплект с программой входит только два скина (дизайна интерфейса), дополнительные же скины можно скачать на сайте программы:

http://www.mmbuilder.nm.ru/autorunmp3.htm

ОГРАНИЧЕНИЯ

Для работы программы в операционных системах Windows98SE, NT и ниже, требуется библиотека msvbvm60.dll, которая устанавливается пользователем самостоятельно и в комплект операционных систем не входит. Если у вас нет этой библиотеки, вы можете скачать и установить её (скачать сейчас!). В операционных системах ME/2000/XP эта библиотека уже имеется.

Однако следует заметить, что файл msvbvm60.dll требуется лишь для работы Мастера настройки. Настроенная программа, записанная на компакт-диск вместе с музыкальными файлами, будет работать на любых операционных системах Windows без каких-либо ограничений.


Ссылки

Программа сделана с помощью мультимедийного конструктора Multimedia Builder. Это уникальное программное средство для создания не только самозапускаемых оболочек для CD, но и многих других приложений мультимедийного содержания. Подробнее о Multimedia Builder вы можете узнать на наших ресурсах в Интернете:

http://www.mmbuilder.nm.ru/
http://www.clubrus.kulichki.net/mmb.html

Посмотреть, есть ли новая версия или скин, можно на странице программы:

http://www.mmbuilder.nm.ru/autorunmp3.htm

Написать отзывы, предложения и критику о программе доступно на форуме по адресу:

Автоплей-меню для мр3-коллекций - Форум Клубрус

И, наконец, последнюю версию собственно программы Multimedia Builder, если она вас заинтересовала, можно поискать в сети по адресам:

http://www.mediachance.com/

http://www.mmbgroup.com/news/


О программе

Автоплей-меню для мр3-коллекций, v 3.3

Автор - as-master, e-mail: as-master@km.ru
Программа сделана с помощью мультимедийного конструктора Multimedia Builder.

Все замечания и предложения о программе автор просит присылать на E-mail.

БЛАГОДАРНОСТИ

Rush - за модули InputBox.dll и TextBox.dll, использованные в программе.
PolN - за скрипт редактирования плейлистов.
Всем моим друзьям и членам клуба ММВ - за ценные советы :)

ноябрь, 2005 г.


Настройка музыкальной коллекции

Перед тем как начать...

...если вы готовите музыкальную коллекцию для последующей записи на компакт диск, создайте на компьютере отдельную папку для музыкальной коллекции (например, с названием "autorun") и поместите туда файлы autorun.exe, autorun.inf, Help.chm, а также папку Skins с имеющимися у вас файлами скинов. После этого запустите файл autorun.exe и следуйте инструкциям Мастера настройки.

Если программа будет использоваться только на компьютере, то вы можете создавать сколько угодно коллекций, каждый раз размещая указанные файлы в отдельные папки с именами этих коллекций (например, "Мастера джаза", "Дискотека 80-х" и т.д.). Затем останется только сделать ярлыки для файлов autorun.exe с разными именами в удобном месте.


Настройка музыкальной коллекции

Выбор дизайна оформления

Программа имеет сменные скины, которые можно будет менять также и во время её выполнения. Однако запускаться программа будет с тем скином, который выбран во время работы Мастера настройки. Доступные скины отображаются в списке. Чтобы выбрать нужный скин, просто выделите его название.

В базовом комплекте программы содержится четыре скина. Дополнительные скины можно скачать на сайте разработчика. Программа не может работать без наличия хотя бы одного файла скина.

Вы всегда сможете вернуться к этой странице, чтобы выбрать другой скин и запомнить его в настройках. Для возврата к мастеру настройки из уже настроенного интерфейса нажмите клавиши Ctrl+T. При этом программа закроется и нужно будет запустить её заново.

ВНИМАНИЕ! При работе программы, записанной на CD, настройки недоступны!


Настройка музыкальной коллекции

Выбор количества сборников, их названий, а также другие настройки

На этой странице Мастера напишите названия музыкальных сборников, которые будут включены в музыкальный альбом. Максимальное количество сборников равно 12. Максимальное количество знаков в названии каждого сборника - около 50.

Каждое название должно начинаться с новой строки и занимать ровно одну строку. Промежутков между строками быть не должно.

На этой же странице вы можете сделать и другие настройки:

Не начинать автоматическое воспроизведение при выборе нового сборника - при установке флажка на этой опции музыка не будет начинать проигрываться сразу при выборе другого сборника в меню. Это может быть удобно, когда вы слушаете один сборник, но хотите посмотреть информацию о других сборниках. Однако при окончании текущей проигрываемой песни начнётся воспроизведение следующей композиции из того плейлиста, который выбран в настоящее время.

Не начинать автоматическое воспроизведение следующего сборника при окончании текущего - по умолчанию в программе начинается воспроизведение следующего сборника при окончании текущего. При установке флажка на этой опции воспроизведение будет останавливаться при завершении проигрывания всего плейлиста текущего сборника. Запускать воспроизведение следующего сборника нужно будет вручную.

Запретить включение экранной заставки во время работы музыкального альбома - выбирайте эту опцию, если вы хотите, чтобы скринсейвер не запускался во время работы вашей музыкальной коллекции.

Запретить кнопку переключения скинов - при выборе этой опции кнопка переключения скинов "на лету" не будет отображаться в интерфейсе программы. Это может быть полезным при записи программы на компакт-диск, когда вы хотите сделать музыкальный альбом только с данным конкретным скином (интерфейсом).

Вы всегда сможете вернуться к этой странице Мастера настройки, чтобы отредактировать названия сборников, их число, и изменить сделанные ранее прочие настройки. Для возврата к мастеру настройки из уже настроенного интерфейса нажмите клавиши Ctrl+T. При этом программа закроется и нужно будет запустить её заново.

ВНИМАНИЕ! При работе программы, записанной на CD, настройки недоступны!


Настройка музыкальной коллекции

Загрузка музыкальных файлов и картинок

Выберите картинку для оформления текущего сборника и укажите музыкальные файлы для формирования плейлиста. Выбранные вами картинки будут сохранены в папке Data в каталоге с программой (то есть в том каталоге, куда вы поместили файл autorun.exe). Плейлисты будут созданы автоматически после загрузки музыкальных файлов и сохранены в той же папке.

Если загруженная картинка вас не устраивает, загрузите другую - новая картинка автоматически заменит ранее загруженную. Для каждого сборника предусмотрена загрузка только одной картинки.

Чтобы пролистывать сборники, нажимайте кнопки "<" и ">" в правом верхнем углу.

В версии 3.3 программы добавлена возможность редактирования плейлистов - добавление и удаление музыкальных файлов. Однако - ВНИМАНИЕ! - изменять содержание плейлистов можно только ДО ТОГО, как вы произвели их автоматическое редактирование на последней стадии настройки альбома, подготавливающей его к записи на компакт-диск. Редактирование плейлистов вручную после этой операции приведет к ошибкам в работе программы. При использовании музыкального альбома только на компьютере, при условии, что вы пропускали шаг Мастера по автоматическому редактированию плейлистов, вы можете редактировать их вручную без ограничений.

Двойной щелчок по названию композиции в плейлисте позволяет запустить предварительное прослушивание файла.

Вы всегда сможете вернуться к этой странице, чтобы отредактировать плейлисты и изменить картинки. Однако при подготовке альбома для последующей записи на компакт-диск существуют ограничения, о которых подробнее сказано ниже.

Для возврата к мастеру настройки из уже настроенного интерфейса нажмите клавиши Ctrl+T. При этом программа закроется и нужно будет запустить её заново.

ВНИМАНИЕ! При работе программы, записанной на CD, настройки недоступны!


Настройка музыкальной коллекции

Добавление комментариев к музыкальным сборникам

На этой странице Мастера настройки вы можете добавить текстовые комментарии к музыкальным сборникам. Наберите текст комментария к текущему сборнику и нажмите кнопку "Сохранить". Текст можно вставить и из буфера обмена.

Чтобы пролистывать сборники, нажимайте кнопки "<" и ">" в правом верхнем углу.

Вы всегда сможете вернуться к этой странице, чтобы отредактировать комментарии. Для возврата к мастеру настройки из уже настроенного интерфейса нажмите клавиши Ctrl+T. При этом программа закроется и нужно будет запустить её заново.

ВНИМАНИЕ! При работе программы, записанной на CD, настройки недоступны!


Настройка музыкальной коллекции

Подготовка альбома для записи на компакт-диск

ВНИМАНИЕ!!! Обязательно прочитайте это перед тем, как предпринимать какие-либо действия на этой странице Мастера настройки.

При использовании музыкального альбома только на компьютере этот шаг Мастера нужно пропустить и вернуться на предыдущую страницу, на которой нажать кнопки "Далее" и кнопку "Готово" на всплывающем окне. Дело в том, что сформированные вами плейлисты имеют абсолютные пути к файлам (например, D:\Music\Paul Mauriat\Paul Mauriat - Love Is Blue.mp3) и где бы ни находилась сама программа autorun.exe, эти файлы всегда будут найдены (нужно только, чтобы в одном каталоге с программой находилась и созданная папка Data со всеми файлами настроек, которые образуются у вас автоматически).

При записи же альбома на компакт-диск пути к файлам должны быть относительными, ибо хоть и известно, что файл лежит, например, по адресу E:\Music\Paul Mauriat..., то даже буква устройства CDROM на другом компьютере может оказаться другой. Поэтому программа сама сможет отредактировать все плейлисты так, что после записи альбома на CD плейлисты будут работоспособны.

При этом разумно сразу же и скопировать папки с музыкой для выбранных плейлистов в каталог назначения (то есть в каталог с программой). Для этого, перед тем как нажать кнопку "Готово", установите флажок на пункте "Скопировать папки с музыкой в каталог назначения".

Редактирование плейлистов и копирование файлов займет некоторое время. Пожалуйста, ждите.

После того как плейлисты будут отредактированы таким образом, что пути в них станут относительными, повторное копирование музыкальных файлов станет невозможным, потому-что для этого используется информация о местоположении файлов из самих плейлистов, которая после редактирования утратит часть пути, содержащую имя диска и все имена папок, кроме последней папки. Поэтому производите редактирование плейлистов и копирование файлов только в самый последний момент, когда вы уверены в том, что настройка вашего музыкального альбома завершена и изменения в этой части вноситься уже не будут.

По этой же причине нельзя изменять содержание плейлистов на третьей странице Мастера настройки: повторно загружать плейлисты, добавлять в них файлы и удалять их, если музыкальные файлы уже скопированы в каталог назначения. Если всё же такая необходимость возникла, удалите все скопированные папки с музыкой, а также все плейлисты из папки Data (файлы list1.m3l, list2.m3l и т.д.) и загрузите все плейлисты повторно.


Настройка музыкальной коллекции

Запись альбома на компакт-диск

Просто запишите на компакт-диск все файлы и папки, которые у вас образовались после настройки в каталоге с программой (в нашем примере это папка "autorun") . У вас должны там быть папки с музыкой, которые вы выбрали во время настройки, а также папка Data, содержащая файлы настроек: плейлисты, картинки, комментарии, а также папка Skins с файлами скинов. В корне этого каталога (т.е. папки "autorun" в нашем случае) должны лежать файлы autorun.exe (собственно программа) и autorun.inf, который нужен для обеспечения автозапуска компакт-диска после вставки его в дисковод.

Не изменяйте имя исполняемого файла - программа не запустится вообще. После записи альбома на компакт-диск и запуска его оттуда переход к странице настроек будет уже недоступен.


Горячие клавиши управления альбомом

Right - перемотка вперед на 10 секунд
Left - перемотка назад на 10 секунд
Ctrl+Right - следующий трек
Ctrl+Left - предыдущий трек
Space - пауза/воспроизведение
S - стоп
P - начать воспроизведение
Home - увеличить громкость
End - уменьшить громкость
H - вызов справки
M - свернуть
Alt+X - выход

ВНИМАНИЕ! В скинах версии 3.0 горячие клавиши не работают. Если у вас остались эти скины, пожалуйста, перезагрузите скины версии 3.3 (ссылка на сайт здесь).


Как сделать собственный скин

А можно сделать собственный скин? - сразу спрашивают те, кому программа понравилась, но имеющиеся скины не очень подходят для создания конкретной мр3-коллекции. Конечно, да. Однако вы должны владеть некоторыми навыками работы с Multimedia Builder, так как именно на ней и сделано автоплей-меню и все скины к нему.

Для упрощения вашей задачи автор программы сделал для вас шаблон скина, в котором написаны все основные скрипты (сценарии) для его правильной работы. Шаблон скина можно скачать на странице программы, размер файла 18 Кб, или непосредственно по этой ссылке.

В архиве с шаблоном вы найдете подробную инструкцию, как и что нужно сделать. Если вы до этого не имели дела с Multimedia Builder, рекомендуем изучить наши уроки, найти которые можно на сайте поклонников программы Multimedia Builder.

Разумеется, для создания шаблона вам придется скачать и установить и саму программу Multimedia Builder версии не ниже 4.9.6.2 (другое название версии - 4.9.6а)/ Ссылки на загрузку вы найдете на указанном выше сайте.

Если вы сделаете хороший, по вашему мнению, скин, то можете прислать его нам, и если он понравится автору программы, то будет выложен на сайте в числе прочих скинов.

Успехов вам в творчестве!